Saturday, April 6, 2013

How to Upgrade from OBIEE 11.1.1.6.X to 11.1.1.7 on linux

Hi Friends ,

Today we will see how to upgrade from OBIEE 11.1.1.6.x to 11.1.1.7 version.

In this example I am taking OBIEE 11.1.1.6   and upgrading it to  OBIEE 11.1.1.7 Version.

Your Best Friend to help is oracle Upgrade Documentation.

http://docs.oracle.com/cd/E28280_01/upgrade.1111/e16452/toc.htm.

High-level upgrade path is as follows


There is a  chapter in the upgrade document which says

"Moving from 11.1.1.3, 11.1.1.5, or 11.1.1.6 to 11.1.1.7".

This is you starting point.

http://docs.oracle.com/cd/E28280_01/upgrade.1111/e16452/bi_plan.htm#BABECJJH

Step 1:


Stop all the  OBIEE Stack

Step 2: Patching Weblogic

As we are going to the latest OBIEE. I want to patch the weblogic to the latest version.
We  have a default weblogic 10.3.5 which came from default OBIEE 11.1.1.6.0 Installation.
I am here trying to patch the weblogic 10.3.5  to 10.3.6. 

Why to patch the endeca ?Another  Reason to upgrade weblogic?

If you are planning to use Endeca  better upgrade the weblogic right now... see the screen shot below. Endeca supports  10.3.6





Note : What versions of weblogic is supported for  OBIEE

 



Patch number  13529623 is required to patch the weblogic from 10.3.5 to 10.3.6, download it from oracle support.










Run the following command to start the upgrade process













































































































































































That's it we have patched the Weblogic Server


Step 3 : Upgrading the BI Domain


For this one you have to download the OBIEE 11.1.1.7.0  Software(bishiphome)




  
Linux Tip :  If you want to unzip all the Linux files at the same time use the following command






























































































































































































































































































Click Finish and you are done with  Installation.

Step 4:  

Start the Node Manager and Weblogic in linux






Step 5: Upgrading MDS and BIPLATFORM Schemas









Starting the  Patch set assitant







































































































Click on the connect button it will automatically populate the MDS Schema Details


























*Enter the DEV_MDS   Schema password you gae during the OBIEE installation and click " NEXT"*






























































































































Step 5:  For all the remaining steps in the oracle documentation  ( 6-14)  As said in the document we are gonna use Configuration Assistant.













































































































































































































That's it done with  configuration 

You can now login to OBIEE URL



 Oracle Business Intelligence  Banner etc are misssing... If you have the same problem flush your cache....

After clearing the cache everything looks good as below.























Even Weblogic is upgraded to the 10.3.6





















The only part I am missing is as follows




Need to do some more reading.... I know while installing OBIEE... we all select the RTD option as below...




Will do some research  on upgrading RTD ( Real -Time Decisions)

and update the upgrade process...

HAPPY  UPGRADING......

Thanks
Venkat

29 comments:

  1. Thanks for this article, very informative.

    ReplyDelete
  2. Thanks for this article, it is great and clear explainative,
    I am using 11.1.1.5 and wanted to upgrade to 11.1.1.7 , will the complete procedure going to be same or there needs to be some changes in the above steps(if i am upgrading from 11.1.1.5 to 11.1.1.7)

    ReplyDelete
  3. Thanks for sharing this. I have been looking for instructions to upgrade 11.1.1.6.X to 11.1.1.7 on Linux. I have not found anything as useful and informative as this post.

    ReplyDelete
  4. Great article far better than Oracle's piss-poor upgrade document

    ReplyDelete
  5. This is an excellent guide on how to update OBIEE 11g 11.1.1.7.
    I need your knowledge'm doing this same process of updating windows environment but when run the Business Intelligence Configuration Assistant. but in step configuration progress gives me the following error:

    JRF Upgrading Shared Libraries
    error
    WLST Script task failed with status 1
    Step Upgrading Shared Libraries JRF failed.
    Configuration Action "Upgrading Shared Libraries" has failed.


    I need your help could leave your comments

    ReplyDelete
    Replies
    1. I am experiencing the same issue. Were you or anyone else able to find a resolution?

      Delete
  6. Running on Linux 64 bit, the process stops at restarting Admin Server and never comes back . Any pointers help ?

    ReplyDelete
  7. Thanks for the precise steps, but i encountered a problem while running config.sh. First time while i was running config.sh i got an error so i tried running again, screen wouldn't move further Weblogic creddetails screen even i give appropriate details. When i tried to follow manual steps then i realized that config.sh is not smart enough to pick up from when it left. It was failing becase during first run BI Domain already got deregistered, config is trying to deregister again and fails. If you end up in this, check 2 things:
    1. Make sure your WL console is in Released mode not in "Lock & Edit"
    2. Register manually as below , Reference metalink note:1546753.1
    $ORACLE_INSTANCE/bin/opmnctl registerinstance \
    -adminHost \
    -adminPort 7001
    3. Retry config.sh
    Hope this helps someone in my situation

    ReplyDelete
  8. Excelent document, unfortunately your graphics seem to be vanishing

    ReplyDelete
  9. Does anyone know if init blocks authentication is still supported in 11.1.1.7? That what we are using in 11.1.1.6.

    ReplyDelete
  10. Yes it is still supported ...but not recommended by oracle...

    ReplyDelete
  11. Hi Venkat,

    This is for the in-place upgrade. Do you have the steps for out-of-place upgrade?

    I have got new fresh installation of obiee 11.1.1.7.0. Now I want to migrate all configurations and data from 11.1.1.6.0 to 11.1.1.7.0.

    Appreciate any help.

    Thanks,
    Rajib

    ReplyDelete
  12. Hi Venkat,

    Thanks for sharing detail steps for up gradation, I am planing to upgrade from 11.1.1.5 to 11.1.1.7 (windows 64 bit).
    we have wls 10.3.5 and jdk 1.6 in place.
    among these 2 which one needs to upgrade first jdk 1.6 to 1.7 or wls 10.3.5 to 10.3.6
    Thanks &regards,
    arun.

    ReplyDelete
  13. Hi Venkat,

    I am trying to upgrade on my virtual box OBIEE from 11.1.1.5(simple install) to 11.1.1.7 using your steps.
    I was able to patch the Weblogic 10.3.6 but the problem is that I don't have enough space for pasting in OBIEE 11.1.1.5 VB path the installer for OBIEE 11.1.1.7.
    Can I run the installer from an external HDD( partition) or can you please advise what should I do in this situation?
    Thank you in advance

    ReplyDelete
  14. Hi Venkat,

    I am trying to upgrade on my virtual box OBIEE from 11.1.1.5(simple install) to 11.1.1.7 using your steps.
    I was able to patch the Weblogic 10.3.6 but the problem is that I don't have enough space for pasting in OBIEE 11.1.1.5 VB path the installer for OBIEE 11.1.1.7.
    Can I run the installer from an external HDD( partition) or can you please advise what should I do in this situation?
    Thank you in advance

    ReplyDelete
  15. Increase your Virtuial box space. It can be found on oracle sample apps user guide on how to oncrease virtual box space.

    Thanks
    Venkat

    ReplyDelete
  16. guys I am 2 servers - A running on 11.1.1.6.0 and B running on 11.1.1.7.0
    So far all the development was done on server A.
    Now we have to start using server B (without uninstalling/upgrading OBIEE on server A)
    What I understand is that server A RPD has version 318 and server B has 325.
    My question is: How do I upgrade RPD and catalog of server A so that I can use them on server B

    ReplyDelete
  17. Hi Hitesh,

    Take your RPD from machine A and Open Admin Tool on machine B and Open your RPD. Once Open, save it to desktop on your computer. Now you will have V325 RPD. Deploy this RPD to Server B.

    For catalog , just move your catalog to Machine B and restart all services...

    Once done, go to Administration tab in presentation services and do scan and update the catalog objects .. That will upgrade your reports to 11.1.1.7.

    That's it ... You are all set fro 11.1.1.7 version

    Thanks
    Venkat

    ReplyDelete
  18. hi... this looks awesome to catch up.

    My quest is does catalog and rpd gets auto upgraded to new versions ???

    ReplyDelete
  19. @fiaz.. Yes.... In some cases all the reports will not be upgraded. If so, you have to go to Administrator > Update catalog objects manually...

    ReplyDelete
  20. Hi Venkat,

    Thank you for the useful information,
    I had unarchive my reports (shared folders ver 11.1.1.3) to the shared folder obiee 11.1.1.7 then restart all services and go to Administration tab in presentation services and do scan and update the catalog objects but the dashboard still not appear in my obiee 11.1.1.7
    Is there any step I have missed?

    Thanks

    ReplyDelete
    Replies
    1. @Cecilia Check permissions on the catalog..

      Thanks
      Venkat

      Delete